f0fyf

f0fyf

mercredi 6 mars 2019

A propos de CubicSDR

Plusieurs personnes m'ont fait remonter des difficultés pour installer CubicSDR actuellement. Il se trouve que certaines librairies necessaires ont évolués et ne sont plus vraiment compatibles d'où la création d'erreurs lors de la compilation. Il s'agit notament des librairie libpng, wxopengl et wxwidget. J'ai farfouillé un peu dans les fichiers et modifié certaines valeurs et dépendances et cela à l'air de fonctionner ici .. quelques bugs mineurs mais en cours de résolution.
Il faudra donc récupérer cubicSDR comme stipulé dans mon billet : https://f0fyf.blogspot.com/2016/10/cubicsdr-une-alternative-gqrx.html
Il faudra bien excécuter le script et attendre qu'il se termine .. même avec les erreurs.
Une fois ceci fait, il faut installer la librairie libpng12 en fonction de votre machine (32 ou 64 bits)
- On récupère l'archive, soit 32, soit 64 bits ici :

- On ouvre un terminal et on lance la commande qui va décompacter et installer ce paquet (exemple pour la version64 ): 

$ sudo dpkg -i libpng16-16_1.6.28-1_amd64.deb

Il faut maintenant récupérer le fichier de CubicSDR modifié ici :
CubicSDR

Un fois copié sur votre disque dur, il vous faudra le placer et le décomprésser OBLIGATOIREMENT dans le répertoire /CubicSDR/src/   

$ tar -xzf CubicSDR.tar.gz

Pour lancer CubicSDR, il faudra juste faire un clic droit sur le fichier et choisir l'option "ouvrir dans un terminal" .. tout devrait alors fonctionner. 
Sinon,il y a Gqrx, bien plus complet et facile à installer ;) 


2 commentaires:

  1. 73 F0FYF de F6GIS
    Merci pour ton blog qui est une mine d'or pour l'om Linuxien.

    Peux tu me dire si SDRPlay RSP1 refonctionne avec cette méthode ?
    Merci

    RépondreSupprimer
  2. Bonsoir
    Normalement, les librairies pour le sdrplay sont présentes mais je n'ai pas testé, n'ayant pas de sdrplay sous la main. donc à voir ;) S'il fonctionnait avec l'ancienne version, cela ne devrait pas poser de soucis particulier.
    73 - Jeff

    RépondreSupprimer